ComTech: IT Support Stirling
TwitterFacebookGoogle

Windows hasn’t left the building just yet

Anyone who regularly reads this blog will know that I have recently decided to run my business using Android while still keeping a Linux netbook for configuring routers.  I find Android very easy to use and I enjoy using Linux so this setup works for me and it works well.  I also still have a Mac (now fixed and installing Yosemite as I write this) which comes out now and again as I have some clients who use them but one omision you will have noticed is a Windows based system.  I do have Windows virtual machines setup on a Debian Linux server but I use them so rarely that it is not actually worth mentioning.  In my business Windows hardly gets a look in.

There have been numerous articles floating around the internet over the last 12 months about the aparent demise of Microsoft and that Windows will slip away into obscurity. This is not going to happen anytime soon as Windows is so entrenched in the corporate world it would take something monumental to shift it.  Yes there are some businesses like mine who decide they can get by without Windows but having Windows in a business environment (in some description) is the norm at the moment.

How much of a norm I found out last week.  A lot of my work at the moment revolves around Cisco and the installation of routers and switches. Alongside this I also install quite a few Verizon GSM modems and Viprinet VPN routers.  It was while installing a Viprinet VPN router last week I got caught out.

Install Vipinet and connect up aerials – check.

Connect up netbook to start configuration – check.

Run exe file – bugger.

Exe files as a rule don’t run under Linux (this one didnt even under Wine) and I didn’t have a Windows machine with me.  Not being able to run the exe file meant not being able to start the configuration, which meant I would have to come back to site again and since the site was in Irvine that meant another 134 mile round trip.  This was turning out to be one of those days.

So long as manufacturers use exe files to setup hardware there will still be a need for Windows. Will this change over time? Maybe but at the moment I think it is time to dig out my old Acer Aspire netbook for thoses times when I have no choice but to use Windows.

About the Author

P1020114

Hi I’m Chris Wakefield the owner of ComTech IT Support. I provide Windows, Mac and Linux based IT Support to small businesses in Stirling, Alloa and Falkirk.

Follow @Comtech247 on Twitter

Springfield House, Laurelhill Business Park, Stirling, FK7 9JQ Tel No: 01786 406448

   Welcome to ComTech

ComTech_12Computers are everywhere these days and here at ComTech we know how valuable IT is to your business.

Established in Stirling adjacent to the majestic Ochil Hills since April 2010 ComTech provides IT Support to small businesses throughout Scotland. Even though we are based in Stirling we have clients in Glasgow, Perth, Edinburgh and as far afield as Inverness.  Here at ComTech we are not afraid to travel!!

Whether your servers go down, your laptop stops working or your router is no longer functioning correctly ComTech is willing, but more importantly able, to fix your problems and get your systems back up and running as quickly as possible.ComTech_Roadtrip

Our engineers are fully qualified and experienced in Cisco, Windows, Linux and OS X and have more than enough knowledge to fix any issues that you might have.

In the beginning ComTech was founded on one main principal “Provide the customer with the quality and service they expect” and that still rings true today.

Our clients range from home businesses to 25 employees or more but it doesn’t matter what size you are as every business is treated equally and will receive the same level of service.

We a very ‘social company’ so why not drop by on either Twitter or Facebook and say hi.  It is always good to meet new people!!

Here at ComTech “WE MAKE IT HAPPEN”

Terms and Conditions

fsb_logo

Configuring vlans on a Cisco switch


Today I will show you how to configure vlans on a Cisco switch.  For this tutorial you will need to establish either a console , telnet or ssh session to your switch and use the following commands.

Configuring a new vlan

Comtech1#configure terminal

Comtech1(config)#vlan 2

Comtech1(config-vlan)#name Working-vlan

Comtech1(config-vlan)#exit

 

Now we need to assign ports on the switch to the new vlan

Comtech1(config)#interface range fastethernet 0/13 – 22

Comtech1(config-if)#switchport access vlan 2

Comtech1(config-if)exit

 

Don’t forget to save the configuration!!!

Comtech1#copy running-config startup-config

About the Author

P1020114

Hi I’m Chris Wakefield the owner of ComTech IT Support. I provide Windows, Mac and Linux based IT Support to small businesses in Stirling, Alloa and Falkirk.

Follow @Comtech247 on Twitter

 

How to configure a Cisco switch with an ip address


Today I will continue the Cisco theme and show you how to configure a Cisco switch with an ip address.  For this tutorial you will have to connect to the switch using a console session.

Lets start.

Comtech1#configure terminal

Comtech1(config)#interface vlan 1

Comtech1(config-if)#ip address 192.168.1.199 255.255.255.0

Comtech1(config-if)#no shutdown

Comtech1(config-if)#exit

 

Now we need to set the default gateway:

Comtech1(config)#ip default-gateway 192.168.1.1

Comtech(config)#exit

 

Don’t forget to save the configuration!!!

Comtech1#copy running-config startup-config

About the Author

Hi I am Chris the owner of ComTech. I provide IT Support, Laptop repairs and Computer repairs to both personal and business clients in and around Stirling. For a list of what I can offer you why not visit my website www.comtech247.net where you will find my blog, testimonials, services and much more.  Start supporting a local business today so I can start supporting you.

If you found this blog useful then why not sign up to my RSS Feed for news, tutorials, views and general techie stuff!!

 

How to configure basic passwords and a hostname on a Cisco switch


Today I will show you how to configure basic passwords and a hostname on a Cisco switch.  For this tutorial you are going to have to open up a console session to your switch.

First we need to set an enable password:

Switch>enable

Switch#configure terminal

Switch(config)#enable secret c7ed2bd92a (sets enable password)

 

Now we need to set the hostname of the switch:

Switch(config)#hostname Comtech1 (sets the switch hostname to Comtech1)

 

Next we need to configure console access:

Comtech1(config)#line console 0

Comtech1(config-line)#password bob2 (sets console password to bob2)

Comtech1(config-line)#login

Comtech1(config-line)exit

 

We will now set passwords for ssh and telent access to the switch:

Comtech1(config)#line vty 0 15

Comtech1(config-line)#password BigBlue (sets ssh and telnet password to BigBlue)

Comtech1(config-line)#login

Comtech1(config-line)#exit

Comtech1(config)#exit

For the changes to take effect we have to save them in the startup-config file so:

Comtech1#copy running-config startup-config

And that’s it.  Next time you connect to your switch either through a console, shh or telnet session you will be asked for the relevant passwords.

About the Author

P1020114

Hi I’m Chris Wakefield the owner of ComTech IT Support. I provide Windows, Mac and Linux based IT Support to small businesses in Stirling, Alloa and Falkirk.

Follow @Comtech247 on Twitter

 

 

How to establish a Cisco console session on LInux

Today we are going to use Linux to establish a console session with a Cisco Catalyst 2950 switch.  I will be using Linux Mint 10 but the procedure is exactly the same on all the other major distributions.

First we need a client to establish the connection, so we need to download PuTTY. PuTTY is an open source telnet/ssh client which can also connect using serial links.  It can be found here or can be downloaded through your distributions repositories.

Before we use PuTTY we need to find out the name of the serial line we will be connecting to.  Open up a terminal and type:

dmesg |grep tty


You should get something similiar to the following:

chris@chris-desktop ~ $ dmesg |grep tty
[    0.000000] console [tty0] enabled
[    0.584757] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    0.585003] 00:06: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 3560.733194] usb 2-2.3: pl2303 converter now attached to ttyUSB0

Because I am using a USB to serial connector my serial name is ttyUSB0.

Now open up PuTTY and you should now be faced with the configuration screen below:

Scroll down the categories on the left until you come to serial.  Click on this to get the screen below:

In the box serial line to connect to change the default value to the name of the serial line you are connecting to (for instance mine would be /dev/ttyUSB0 achieved earlier through the terminal).  Make sure that all the other settings are the same as the screenshot above.

Once this has been configured go back to the main PuTTY screen click on serial and enter the ip address of the switch you are connecting to.  Once this information has been entered click open.  You should now be faced with a console session to your switch.

About the Author

P1020114

Hi I’m Chris Wakefield the owner of ComTech IT Support. I provide Windows, Mac and Linux based IT Support to small businesses in Stirling, Alloa and Falkirk.

Follow @Comtech247 on Twitter

 

 

How to configure sub-interfaces on a Cisco router

Today we are going to configure sub-interfaces on a Cisco router. We will configure the Fast Ethernet port 0/0 on a 1841 router to have two sub interfaces for vlans 1 and 2.

Hostname(config)#interface fastethernet 0/0
Hostname(config-if)#no ip address
Hostname(config-if)#exit

Hostname(config)#interface fastethernet 0/0.1
Hostname(config-if)#ip address 192.168.1.1
Hostname(config-if)#encapsulation dot1q 1 native
Hostname(config-if)#exit


Hostname(config)#interface fastethernet 0/0.2
Hostname(config-if)#ip address 192.168.2.1
Hostname(config-if)#encapsulation dot1q 2
Hostname(config-if)#exit

Please note that the numbers at the end of the encapsulation dot1q x command indicate the vlan that the encapsulation will be active for.

About the Author

P1020114

Hi I’m Chris Wakefield the owner of ComTech IT Support. I provide Windows, Mac and Linux based IT Support to small businesses in Stirling, Alloa and Falkirk.

Follow @Comtech247 on Twitter

 

 

CyberChimps
Follow

Get every new post delivered to your Inbox

Join other followers

WordPress SEO fine-tune by Meta SEO Pack from Poradnik Webmastera
WP Like Button Plugin by Free WordPress Templates